A few days ago Unity 5.0 released along with Unity 2D 5.2 for machines does not support the minimum hardware requirements for Unity. Both of them are available to update