Recently many users reporting deb package installation error using Ubuntu Software Center On Ubuntu 11.10 Oneiric Ocelot. So here are a couple of ways to install deb package